
Importing AVCHD Footage into Avid

Prerequisites
- Avid Media Composer 6.5.2
- AVCHD AMA Plug-in 1.2
- Mountain Lion 10.8.2

Step By Step
- Plug in your external hard drive. This will be where you store all your Avid Projects and Media. For example, I have plugged 

in a drive called Student Drive. To keep things neat and tidy, I have created a new folder called 01 - Avid Projects to 
store all my Avid projects  on this drive. You can use the shortcut key COMMAND + SHIFT + N to create new folders from 
within Finder.

- Open Avid Media Composer from the Dock:
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- Tick the External button,  as  we want to save our Avid project on our external drive.  Once the External  checkbox is 
selected, then click the open icon in the Folder section of the window (yes - sadly, this is very unintuitive).

- In the Project Directory window then select the 01 - Avid Projects folder we created earlier and click Open.
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- You can now see in the Folder section of the window that the 01 - Avid Projects is selected. Let’s create a New Project.

- The New Project window can be a bit daunting at first viewing. However for what we want to do, the default settings will be 
fine. Just type a suitable Project Name, then ensure 1080p/25 is selected from the Format drop down. Everything else 
should be as per the screenshot below. Click OK when you’re done.
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- You can now see that the NX5 Footage project has been created, and if you look at the Folder section, you can see that 
it’s been created on the 01 - Avid Projects folder on our external hard drive. So far so good! Let’s  now open the project 
by clicking OK.

- The first thing you should ALWAYS do when you first open a project is make sure all the Media Creation settings are 
correct. Click the Settings tab in the main window:
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- From the Settings tab navigate down to Media Creation. The easiest way to do this  is just click any item in the menu 
then type M on your keyboard. Double click the Media Creation text to open the settings window.

- The first thing I always do is  tick the three boxes on the Drive Filtering & Indexing tab. This prevents Avid for accessing 
the local computers hard drive (i.e. the drive that has Mac OS installed), and other random network drives connected to the 
computer.  For the purposes of this project, we want to store ALL our media on our external hard drive, so ticking these 
three items just makes things a little more fool proof.
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- Then click over to the Import tab. This is where you tell Avid where you want to save any files you import (i.e. if you just 
drag a file from your desktop into a bin). For the purposes of this exercise we will select DNxHD 36 MXF as the format 
(which is a 8-bit, 4:2:2, 36 Mb/sec codex - giving us small file sizes, but still maintaining a really good quality for basic 
editing). Which Video Resolution you decide on really depends on what kind of work you’re doing. 

- Make sure that the Video & Audio drive is set to your external hard drive, and click both the Apply to All buttons  to ensure 
that the Video Resolution and Video/Audio Drive is  applied to all the other tabs (i.e. Capture, Titles, etc.). You can then click 
OK to close the window.

- You are now ready to start bringing in some NX5 footage, but before we do that, I need to explain about a piece of 
technology called Avid Media Access (AMA).

- AMA is a plug-in-based feature in Media Composer, Symphony, and NewsCutter software that enables you to directly edit 
tapeless media without having to copy or import the footage. It works behind the scenes, automatically linking clips from 
the device to a bin in your software. You get immediate and direct access to all AMA media just as you would when 
working with clips stored in the Avid Media Files folder. Essentially,  it allows you to use Avid Media Composer in exactly the 
same way as Final Cut Pro 7 works (i.e.  instead of converting or transcoding media - Final Cut Pro 7 simply “links” to 
existing files on your hard drive).

- For those that have been working on Final Cut Pro 7 previously and are used to the concept of essentially just “linking” to 
media, AMA probably makes a huge amount of sense - but it might also be a bit confusing as to why it has a special 
name, and Avid makes such a big deal out of something so simple. Well, traditionally (i.e. until  Avid Media Composer 3.5) 
you always had to CONVERT ALL your media into an Avid Friendly format (such as DNxHD).  Even today, most editors 
convert all their rushes to something like DNxHD 36 due to a wide variety of reasons - but the biggest being,  media 
management. The thing that makes Avid so powerful, and it’s big advantage over Final Cut Pro 7, is the clever and 
powerful  way it manages media via the Avid MediaFiles folder. AMA basically “breaks” this model - allowing you to store 
media anywhere you want. AMA is very helpful,  fast and powerful,  but it can also be dangerous, as it potentially allows 
editors to be lazy, and not manage their data in a careful and safe manner.
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- For now, let’s just think of AMA as “linking” to files. By default Avid Media Composer automatically has a setting enabled 
called Automatically AMA-link to volumes. What this means is that each time you mount a drive containing footage that 
Avid supports, it will  automatically create a new bin with the same name as the drive, and AMA link to the files  on the drive. 
For example, if we look in our project currently there is only one empty bin (which was automatically created when we 
made our project):

- However,  let’s mount the DMG file which contains  our Test Footage. This DMG is basically an exact clone of everything that 
was originally recorded on the camera’s card - so for the purposes  of this  exercise, let’s just imagine that the DMG file is 
actually a memory stick from the camera. To mount the DMG on a Mac, from Finder simply double click on it.

- From within Finder, we’ll now see a new drive has been mounted called Test Footage. This now appears exactly the same 
as it would if we actually plugged in a physical card from the camera into the computer.
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- If you were on Final Cut Pro 7, you would normally use Log & Transfer to bring in this footage.  However on Avid, with the 
default settings, the software will automatically bring the footage into a new bin, ready to go. You can work with this 
footage straight away. If you jump back into Avid you’ll see a new bin has magically appeared:

- This  feature is very handy for beginners - and does make life a lot easier and quicker,  but personally, I find it a bit annoying, 
that Avid automatically creates a new Bin for you each time you plug in a external hard drive or card. Luckily, you can 
adjust the AMA settings by clicking Settings > AMA.

Thrown Together by Chris Hocking (13-April-2013)
 Page 8



- In the Volume Mounting tab, you can then de-select Automatically AMA-link to volumes. However, for now, let’s just 
leave it checked, and move on.

- We now have a few options:

1. We just just leave the footage “as is” and start editing straight away. Avid will just continue to link to the footage 
in it’s current location. If you have a really tight turn-around, then this might be the perfect option (for example, if 
you’re working for a TV news channel, and you need to quickly throw together a segment).  The negative 
however is  that you’re working with highly compressed AVCHD footage (which will sometimes slow down the 
editing process - just like attempting to edit H.264 files  in Final Cut Pro 7), and the footage is still on the original 
card (or in our case the DMG file). If you disconnect the card or eject the DMG - the footage will go offline.

2. We could copy the whole contents of the card (or in our case the DMG file) to our external hard drive, and then 
manually link to the footage via AMA. The advantage of this is  that you will then have all the footage stored on 
your external hard drive, making things easily to “carry around”. The disadvantage of this  is  that the footage is 
still in it’s  AVCHD format - which again, is not ideal for editing. Also, because of the way Mountain Lion treats 
AVCHD files, finding the MTS files you need to link via AMA is not as simple as  you’d think - but I’ll show you 
anyway.

3. We could import the MTS files into Avid either via drag-and-drop or via the File > Import menu. This is what is 
regarded as the “traditional” method of bringing in files, and will  transcode the MTS files into whatever Video 
Resolution and to whatever drive you set in your Media Creation settings. Traditional imports, although 
sometimes simpler - are normally a lot slower than using AMA, so let’s just skip this option for now.

4. You can bring the files in via AMA, then make use of Avid’s Consolidate/Transcode functionality, allowing you 
to convert the AVCHD media into something a little more editor-friendly. This is the preferred workflow.
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- We have already done option one, so let’s have a quick look at option two. From within Finder, let’s navigate to the Test 
Footage drive.  You’ll see that it contains two folders (AVF_INFO and private). Select them both and copy them (either by 
going to Edit > Copy 2 Items, right-clicking and selecting Copy 2 Items, or by pressing COMMAND + C on your 
keyboard).

- On our Student Drive, let’s create a new folder called 02 - Media, then create a new sub-folder within that called Test 
Footage, and Paste the files in there (you can use the COMMAND + V shortcut key on your keyboard).
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- We now have the footage on our external drive ready to go. But how do we actually access  the footage? Unfortunately in 
Lion and Mountain Lion, Apple has tried to make AVCHD files work more easily with iMovie, and have essentially hidden all 
the actual useful files. What we need to do is  navigate to the private folder, click the AVCHD file, right click on it, then 
select Show Package Contents.

- This  will open up a new window with a single file called BDMV. Again, we need to right-click and selected Show 
Packaged Contents.

- We can now finally see the REAL contents  of the card.  All of the actual media (i.e. the MTS files)  is within the STREAM 
folder.
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- If we wanted to just AMA-link to an individual MTS file (i.e. the actual individual video files), we would jump back into Avid, 
then create a New Bin called AMA Test.

- With the new bin open and selected, we would then click File > Link to AMA File(s)...
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- To speed things up, we would then drag the MTS file from Finder, into the Select file(s) for AMA linking window and 
click Open. This is a really handy tip - and can be used in all Mac OS applications.

- The footage is now successfully imported into our Avid project, ready to work with.
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- However,  even though we’re now linking to the media that’s contained on our external hard drive (so everything in the one 
place - great!)  - we’re still  working with AVCHD files, which is not ideal. So let’s have a look at the fourth option explained 
above and transcode the footage to a more Avid friendly codec.

- To keep things nice and tidy, first up, let’s delete the NX5 Footage Bin  and Test Footage bins, as  we don’t need them 
any more.  Simply right click on the bin, then select Delete Selected Bins or use the Delete Selected Bins option from 
the Edit menu.

- Once you have deleted the two bins, they will appear in your Trash.  Click the Fast Menu button (or Hamburger button as I 
call it), then select Empty Trash to delete the bins permanently.

- You should now only have one bin in your project - the AMA Test bin, which contains the single AMA-linked clip, that’s 
stored on your external hard drive. Neat and tidy - nice!
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- What we want to do now is right click on the clip, and select Consolidate/Transcode.

- Unfortunately, the Consolidate function won’t work in this case, as the consolidation function only works with files Avid 
can read natively - such as DV, XDCAM, P2, etc. Avid Media Composer uses the AMA plugin, to read AVCHD files, so the 
consolidation function simply doesn’t work.

- If you try it, you’ll just get the following error:

Thrown Together by Chris Hocking (13-April-2013)
 Page 15



- However,  what we can do is Transcode all the footage into an Avid friendly format. For the purposes of this example, we’ll 
use DNxHD 36 MXF.

- From within the Consolidate/Transcode window, make sure that Transcode is selected in the top left-hand corner. 
Underneath that, make sure that Video and audio on the same drive(s) is ticked, and that your external drive is 
highlighted (in our case, it’s the Student Drive).

- In the Target Video Resolution section, we have selected DNxHD 36  MXF, as explained previously - however you can 
use whatever format you prefer - for example, you might prefer to use Apple ProRes MXF.

- I generally always tick the Convert Audio Sample Rate and Convert Audio Bit Depth so that I’m confident that the 
audio is in a format that suits the editing process (i.e. 48kHz 16bit). 

- The Target Audio Format allows you to customise what type of file type Avid saves  the audio files to - but for almost 
every case, you can safely leave it as PCM (MXF).
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- Once everything is set up correctly, you can click the Transcode button.  Avid will now convert the AVCHD file into a 
DNxHD 36 file, and you’ll notice a new clip in your AMA Test bin.

- The original  file (00000) is the AMA linked file (you can tell  it’s  AMA, because of the little chain icon). As you can see 
below, this file is located on our external hard drive - in this case called Student Drive.

- The transcoded file (00000.new.01) is the DNxHD 36 file. Again,  because of the Media Creation  settings, it has  saved 
the files on our external hard drive - in this case called Student Drive.

- We can now safely delete the original AMA-linked file (by selecting it and pressing Delete on your keyboard), and start 
cutting with the DNxHD file.

- If we now look on the external hard drive from Finder, we can see that a Avid MediaFiles folder has been automatically 
created, and within it,  is  all our newly created DNxHD 36  video and PCM audio (one file for the left  channel of audio, and 
one file for the right channel of audio). You never really have to worry about the contents of this folder - as Avid does all the 
work. What you do need to do is keep things organised - and try to only have ONE Avid MediaFiles folder for each 
project.
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- As you can only have ONE Avid MediaFiles folder on a drive, the easiest way to manage things is to simply rename the 
folder when you’re switching between projects. For example, let’s close Avid via the Avid Media Composer > Quite Avid 
Media Composer menu (or by simply pressing COMMAND + Q on your keyboard).

- From Finder, let’s navigate to our external hard drive.
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- What we can do once we’ve finished editing with this job, is  simply rename the Avid MediaFiles folder to something like 
Avid MediaFiles - NX5 Footage. As soon as you rename the folder, Avid will no longer see it.

- You don’t HAVE to keep each project separate though. If you have a big hard drive that contains multiple Avid jobs, you 
could just have a single  Avid MediaFiles folder that contains media for multiple projects. However,  as  the Avid MediaFiles 
folder is  essentially managed by the software, you loose some control,  which makes backing up and archiving individual 
projects slightly more tricky.

- In the Post Production community there are two schools of thought. Some companies just have a single MASSIVE Avid 
MediaFiles folder which contains media for all of their jobs, and they use Avid’s internal tools (i.e. the Media  Tool) to 
manage things. However, most companies have a separate “drive” (or Workspace, when they are using Shared Storage - 
such as on an Avid ISIS) for each job, allowing them to easily archive old jobs as soon as they are no longer needed.

- If you want to work on this project again, simply rename the folder back to Avid MediaFiles.

- You can now open Avid Media Composer again, and start cutting away your master piece. Have fun!
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